[RESOLVED] Successful completion of create study - but no folders created

I’m having trouble with create_study command.

Previously I ran create_study successfully in my user directory “/home/theoweiss” and managed to add subject and perform preprocessing. Lately I wanted to work in a different directory “/scratch/theoweiss” but I have encountered a weird issue. Although the output to terminal says “successful completion of task” no directory was created. The only change is a “qunex_container_command” file created in my user directory “/home/theoweiss”.

I’ve uploaded three files - the test file I use for running and the command file (both originally .sh files) and the output that was printed to the terminal.

terminal_output.log (6.1 KB)
test.txt (528 Bytes)
qunex_container_command_2023-12-18_11.10.10.342201.txt (145 Bytes)

Thank you,

Hi Theo,

I had a really long post already written about what you could try, but then I figured that it seems like you are using a docker container, while --bind is for Singularity containers. If you use the home folder it will work because docker automatically binds it. Try this:

qunex_container create_study --studyfolder="/scratch/theoweiss/PreProcessing/qunex/hcp" --dockeropt="-v /scratch/theoweiss:/scratch/theoweiss" --container=${QUNEX_CONTAINER}

So instead of bind, you should use --dockeropt="-v /scratch/theoweiss:/scratch/theoweiss". -v is the docker’s way of binding things.


That was really helpful, it works now.
Thank you