[RESOLVED] Running HCP pipeline on legacy dataset

Dear Jure:

I have a dataset with only T1-MPRAGE and resting-state fMRI. I was wondering if it is possible to use qunex to run HCP pipeline on this dataset? If so, can you be so kind to advice on best to do it?

Many thanks as always!


Ed, yes that is possible up to MSMAll (that command requires some T2w preprocessing outputs). What you want to do is set --hcp_processing_mode=LegacyStyleData and --hcp_t2=NONE starting with hcp_pre_freesurfer (hcp_pre_freesurfer — QuNex documentation). Since you probably do not have spin echo or fieldmap data, you maybe need to set --hcp_avgrdcmethod=NONE as well.

If these apply to the whole study, you can simply set those in your param file when you create batch or in your batchfile if it already exists.

Let me know how it goes.

Best, Jure

Dear Jure:

My apologies for my late reply, and thanks so much for your help indeed!

I forgot to also mention that my resting state fMRI was only performed in one phase encoding direction.

The preprocessings for the T1 were ok, but failed for hcp_fmri_volume with the following error:

Session id: 14212
[started on Friday, 24. May 2024 01:17:46]
Running HCP fMRI Volume pipeline [HCPStyleData] ...
---> PreFS results present.
---> FS results present.
---> PostFS results present.
---> ERROR: invalid value for the hcp_bold_dcmethod parameter!

---> Preprocessing settings (unwarpdir, refimage, moveref, seimage) for BOLD 1
     ... phase encoding direction: AP
     ... ERROR: Unknown distortion correction method: ! Please check your settings!
     ... bold image present
     ... reference image not used
     ... using the HCPpipelines default BOLD mask

Running 1 BOLD images in parallel
---> ERROR: something missing, skipping this BOLD!

HCP fMRIVolume completed on Friday, 24. May 2024 01:17:46

===> Final report for command hcp_fmri_volume
... 14212 ---> HCP fMRI Volume: bolds 1 not ready

Below is my parameter file:

# -------------------------------------
# ---> fMRI Volume parameters
# -------------------------------------
_hcp_bold_echospacing   : 0.000580009
_hcp_bold_echodiff      : NONE
_hcp_bold_dcmethod      : NONE
_hcp_bold_topupconfig   : b02b0.cnf
_hcp_bold_sbref         : NONE
_hcp_bold_sephaseneg    : AP
_hcp_bold_sephasepos    : PA
_hcp_bold_unwarpdir     : PA=y|AP=y-
_hcp_bold_res           : 2
_hcp_bold_gdcoeffs      : NONE
_hcp_bold_doslicetime   : FALSE
_hcp_bold_seimg         : independent
_hcp_bold_movref        : independent
_hcp_bold_prefix        :

Your help is greatly appreciated as always! Thank you very much


Hi Ed,

I believe we had a bug with parsing hcp_bold_dcmethod at some point. Are you using the latest version (0.99.2d)?

Please try providing the value explicitly through a parameter: --hcp_bold_dcmethod="NONE".

If you have some older containers at hand, you can try running with them. I think this was fixed and will be released in the updated version that is coming out soon-ish.

Best, Jure

Hi Jure:

Yes I have been using 0.99.2d.

Ok, let me try to call hcp_fmri_volume explicitly and specify --hcp_bold_dcmethod="NONE" as you suggested, instead of through turnkey, and will update you how it goes.

Many thanks as always.


Hi Jure:

Thanks to your help, I can now run hcp preprocessing on legacy data!

Thanks so much again,