[RESOLVED] Onboarding HCP Data

Hello, when using import_hcp, we are unsure of what folder to direct the “–inbox” path to. Qunex keeps outputting that it can’t parse the files inside our HCP subject folders. We are wondering if this is because our HCP subject folders are not organized in the same fashion as the HCPA001 example subject folder that Qunex provides in the Quick Start tutorial (and also wondering if this command only works when pointed toward raw/unprocessed data). Our folders are organized as follows:

fix extended preproc unproc
100307_3T_Diffusion_unproc.zip 100307_3T_rfMRI_REST1_unproc.zip 100307_3T_Structural_unproc.zip …etc.

ckorponay, hi!

If I understand correctly, the way your dataset is structured and stored is that you have the regular folder structure within which folders that hold all the files related to each sequence are zipped? From your example:


Instead of


If that is the case, QuNex can not process the dataset. Currently, the following options are supported:

  1. The files are fully “dispersed” in the regular file structure.
  2. All the files for a session are zipped within a single package.
  3. The whole dataset is zipped in a single package.

When the files are packaged in another, intermediary level, as in your case, where only files pertaining to sequences are zipped in a package, QuNex currently can not process it. I would suggest that you unzip the packages and then try importing again. The --inbox parameter in this case would point to the folder that holds the individual sessions folders. E.g., if the structure is:


the --inbox should point to /data/hcp_study.

All the best,


1 Like