[RESOLVED] Error using latest version of the Singularity container (0.94.9)


I have been running QuNex without problem using version 0.90.10. However, I recently downloaded the latest version of the Singularity container (version 0.94.9) and I am getting an error when running the run_turnkeycommand using qunex_container. Please, note that the container seems to work fine when I enter the container and work within it. QuNex also works fine if I revert back to version 0.90.10. I am providing an example call below.

Container tag qunex_suite-0.94.9.sif accessed via:

export STUDY_NAME=“HBN_BBRF_rerun”
export RAW_DATA=“${WORK_DIR}/${STUDY_NAME}/sessions/inbox/MR”
export INPUT_BATCH_FILE=“${WORK_DIR}/${STUDY_NAME}/sessions/specs/HBN_BBRF_batch1.txt”
export INPUT_MAPPING_FILE=“${WORK_DIR}/${STUDY_NAME}/sessions/specs/HBN_BBRF_mapping1.txt”
export RUNTURNKEY_TYPE=“local”
export RUNTURNKEY_STEPS=“create_session_info”

qunex_container run_turnkey


Generated by QuNex 0.94.9 on 2022-09-14_08.55.10.286627

e[36m===> Executing QuNex run_turnkey workflow… e[0m

e[32m------------------------ Initiating QuNex Turnkey Workflow ------------------------------- e[0m

/opt/qunex/bash/qx_utilities/run_turnkey.sh: command substitution: line 534: unexpected EOF while looking for matching `"’
/opt/qunex/bash/qx_utilities/run_turnkey.sh: command substitution: line 535: syntax error: unexpected end of file

e[35m → Note: Acceptance Test type not specified. Setting default type to: no e[0m

e[35m → Note: Turnkey cleaning not specified. Setting default to: no e[0m

e[31mERROR: --paramfile flag missing. Parameter file not specified. e[0m


We recently renamed batchfile to paramfile parameter for run_turnkey in 0.94.x, because the actual input file is the header of the batch file or batch parameter file.
The command should work if you change it to something like this


Great, it works now. Thank you,