[RESOLVED] Create_session_info creates faulty session_hcp.txt

Hi there,

Using the command create_session_info gives the following info in the file session_hcp.txt:

hcpready: true
01: :T1w
02: :bold rest

This causes issues when using setup_hcp. Editing those lines to the following seems to resolve the issue.

hcpready: true
01: T1w
02: bold rest

Best wishes,
George

Hi George,

thanks for reporting this. It seems like QuNex tries to insert some data/metadata about the image that does not exist. It would be very helpful if you could maybe upload this sample data somewhere where I can get it. This way, I can test on our end and see exactly what is happening. If this is not possible, no worries I understand completely. In this case, I will have to figure it out manually.

Regards, Jure

Hi Jure,

There will have been missing metadata as there was no T1 .json supplied. For the fMRI I can share the metadata with you here:

{
“Modality”: “MR”,
“MagneticFieldStrength”: 3,
“ImagingFrequency”: 127.761,
“Manufacturer”: “Philips”,
“ManufacturersModelName”: “Ingenia”,
“InstitutionName”: "removed,
“InstitutionalDepartmentName”: “removed”,
“InstitutionAddress”: “removed”,
“DeviceSerialNumber”: “71339”,
“StationName”: “RM3T”,
“BodyPartExamined”: “BRAIN”,
“PatientPosition”: “HFS”,
“ProcedureStepDescription”: “Anillo”,
“SoftwareVersions”: “5.1.9_5.1.9.1”,
“MRAcquisitionType”: “2D”,
“SeriesDescription”: “FE_EPI_27_ANGULADA”,
“ProtocolName”: “FE_EPI_27_ANGULADA_SENSE”,
“ScanningSequence”: “GR”,
“SequenceVariant”: “SK”,
“ScanOptions”: “FS”,
“ImageType”: [“ORIGINAL”, “PRIMARY”, “M”, “FFE”, “M”, “FFE”],
“SeriesNumber”: 401,
“AcquisitionTime”: “18:52:0.850000”,
“AcquisitionNumber”: 4,
“PhilipsRescaleSlope”: 0.858364,
“PhilipsRescaleIntercept”: 0,
“PhilipsScaleSlope”: 0.0300263,
“UsePhilipsFloatNotDisplayScaling”: 1,
“SliceThickness”: 3,
“SpacingBetweenSlices”: 3.3,
“EchoTime”: 0.035001,
“RepetitionTime”: 2.5,
“FlipAngle”: 82,
“CoilString”: “MULTI_COIL”,
“PartialFourier”: 0.5625,
“PercentPhaseFOV”: 100,
“EchoTrainLength”: 45,
“PhaseEncodingSteps”: 80,
“AcquisitionMatrixPE”: 80,
“ReconMatrixPE”: 80,
“PixelBandwidth”: 2051.6,
“PhaseEncodingAxis”: “j”,
“ImageOrientationPatientDICOM”: [
0.997706,
0.0518655,
0.0435089,
-0.0519017,
0.998652,
-0.000298211 ],
“InPlanePhaseEncodingDirectionDICOM”: “COL”,
“ConversionSoftware”: “dcm2niix”,
“ConversionSoftwareVersion”: “v1.0.20181125 GCC4.8.5”
}

Best wishes,
George

Thanks for sending the additional info along. It is very hard for me to fix this as I am unable to reproduce this behavior.

Your session_hcp.txt should actually be:

hcpready: true
01: T1w             :T1w
02: bold1:rest      :bold rest

Could you please also provide the contents of the session.txt file it sits next to session_hcp.txt in the folder structure.

Also, could you provide all the command calls that you execute (starting with create_study).

Thanks!

Hi Jure,

Sure, here you go:

session.txt (303 Bytes)

And the commands used:

Set variables

set WORK_DIR="/home/k1328096/Projects/HMM_22q11/Qunex"
set INPUT_MAPPING_FILE="/home/k1328096/Projects/HMM_22q11/Scripts/mapping_file.txt"
set QUNEX_CONTAINER="/home/k1328096/qunex/qunexcontainer-0.91.7.sif"
set SESSIONS_FOLDER="/home/k1328096/Projects/HMM_22q11/Qunex/sessions"
set BATCH_FILE="/home/k1328096/Projects/HMM_22q11/Qunex/sessions/specs/batch_file.txt"

set SESSION=“1402”

Step 1, make study folder

./qunex_container create_study
–container="${QUNEX_CONTAINER}"
–studyfolder="${WORK_DIR}"

Step 2, import data in BIDS format and create the session.txt mapping files

./qunex_container import_bids
–container="${QUNEX_CONTAINER}"
–sessionsfolder="${SESSIONS_FOLDER}"
–inbox="${SESSIONS_FOLDER}/inbox/BIDS/"
–archive=copy
–overwrite=yes

Step 3, create session_hcp.txt (HCP style) from session.txt

./qunex_container create_session_info
–container="${QUNEX_CONTAINER}"
–mapping="${INPUT_MAPPING_FILE}"
–sourcefile="${SESSIONS_FOLDER}/${SESSION}/session.txt"
–targetfile="${SESSIONS_FOLDER}/${SESSION}/session_hcp.txt"
–sessions="${SESSION}"
–sessionsfolder="${SESSIONS_FOLDER}"

Hi Jure,

Amending the session_hcp.txt file to:

hcpready: true
01: T1w             :T1w
02: bold1:rest      :bold rest

Resolved the issue I’d previously raised with hcp_fmri_volume (with a previous version of qunex): [RESOLVED] Issue running hcp4 / fMRIVolume

Best wishes,
George

Hi george,

Great that the previous issues was resolved!

Could you please also attach the mapping file (/home/k1328096/Projects/HMM_22q11/Scripts/mapping_file.txt), I think it might be the culprit for the issues you are experiencing.

Jure

Hi Jure,

Here you go:

mapping_file.txt (89 Bytes)

Best wishes,
George

Could you try changing the mapping_file.txt into:

#  mapping file
#  ----------------

T1w => T1w
bold rest => bold:rest

And then rerunning the create_session_info command with the overwrite parameter set to yes (--overwrite="yes").

If the above solution resolved your issues, please let us know, so we can mark this issue as resolved. Thanks!

Apologies for the slow reply Jure, that resolved the issue yes.

Many thanks for your help with this!

No worries. I am glad that we fixed your issue!