[RESOLVED] Bold naming issue


Hi I am processing a database with multiple bolds data. For each participant, they can have at most four bolds, two movies (different movies) and two rest. However, different participants can have different number of bolds and I want to distinguish the types of bold they have. So if I use the default mapping of qunex:
bold movieDM => bold:movie1
bold movieTP => bold:movie2
bold rest => bold:rest
Then qunex will map them as bold_1, bold_2, etc. However, for participants that do not have all four bolds, we cannot tell the type of the bold.
So I tried different ways of mapping files. One way seems to work is create a mapping file like this:
bold movieDM => boldMovieDM:movieDM
bold movieTP => boldMovieTP:movieTP
bold rest => boldRest:rest
Then, after the mapping, folder that contains the bold file will be named as “BOLD_1MovieDM”, for example.
However, the problem is when I did “hcp_fmri_volume”, qunex won’t recognize this folder “BOLD_1MovieDM” as bold file and keeps reporting that there is no bold file. I have tried to modify hcp_filename as “userdefined” but still not working.
Could you give me a suggestion on how to create the mapping file so that I can distinguish the four bolds in the following steps? Thank you very much!


export STUDY_NAME="HBN_BBRF_rerun" 

export WORK_DIR="/gpfs/project/aslin/ss2569/Studies"
export INPUT_BATCH_FILE="${WORK_DIR}/${STUDY_NAME}/sessions/specs/hbn_asd_batch_FINAL1.txt"
export INPUT_MAPPING_FILE="${WORK_DIR}/${STUDY_NAME}/sessions/specs/hbn_asd_mapping_version2.txt"  

export RUNTURNKEY_STEPS="hcp_fmri_volume,hcp_fmri_surface,run_qc_t1w,run_qc_t2w,run_qc_bold,map_hcp_data,create_bold_brain_masks"

export QUNEX_CONTAINER="/gpfs/project/aslin/ss2569/software/Singularity/qunex_suite-0.90.10.sif"
export RAW_DATA="${WORK_DIR}/HBN_BBRF_rerun/sessions/inbox/MR"

export RUNTURNKEY_TYPE="local"

qunex_container run_turnkey \
  --rawdatainput="${RAW_DATA}" \
  --batchfile="${INPUT_BATCH_FILE}" \
  --mappingfile="${INPUT_MAPPING_FILE}" \
  --workingdir="${WORK_DIR}" \
  --projectname="${STUDY_NAME}" \
  --path="${WORK_DIR}/${STUDY_NAME}" \
  --sessions="${SESSIONS}" \
  --sessionids="${SESSIONS}" \
  --sessionsfoldername="sessions" \
  --turnkeytype="${RUNTURNKEY_TYPE}" \
  --container="${QUNEX_CONTAINER}" \
  --overwrite="yes" \
  --turnkeysteps="${RUNTURNKEY_STEPS}" \
  --parsessions="1" \
  --dataformat="BIDS" \
  --runparcellations=all \
  --hcp_filename="userdefined" \


     ... ERROR: bold image missing [/gpfs/project/aslin/ss2569/Studies/HBN_BBRF_rerun/sessions/NDARAV082JHA/hcp/NDARAV082JHA/unprocessed/BOLD_1/NDARAV082JHA_BOLD_1.nii.gz]!
     ... reference image not used
     ... using the HCPpipelines default BOLD mask

The folder in my “unprocessed” folder that contains bold data is actually named as “BOLD_1MovieDM”. This seems not recognized by qunex.

Thank you for the help!


We are just in the process of upgrading our mapping logic and the upgrade will be folded into our next release (probably sometime next week). In that update you will be able to manually specify bold numbering.

I will keep you posted about the timeline of this update.

Thanks! I really appreciate it.


The new functionality is included in the new version of QuNex (0.94.0). The version is already on GitLab, it will be on Grace tomorrow and in the form of a container later this week. See the Explicitly assigning bold numbers section of the mapping documentation page.

Please let me know if something is not clear, or if something does not work as it should.