TR value is not read in correctly when running preprocess_conc

Description:

I’ve been using QuNex preprocess_conc command using one of the recent versions of the container (qunex_suite-0.96.2.sif). However I just noticed that the TR value that is passed to the fc_preprocess_conc function is TR=2.5 which is the default value, instead of .7 which is the correct value in the batch file and the stats files in the corresponding …/sessionID/images/functional/movement/ directory.

It seems that up to qunex_suite-0.93.6.sif version, the TR value is read in correctly, but for the later versions, the TR value in the log file is always TR=2.5.

Call:

< Provide the qunex or qunexContainer command that was executed. 
In order to make the issue reproducible, please include all relevant 
information such as where the command was executed from, which 
version of the container was used, and full paths to all files. >

Logs:

 Generated by QuNex 0.96.2 on 2023-01-11_18.40.15.595469
#
------------------------------------------------------------
Running external command via QuNex:

octave -q --no-init-file --eval "try fc_preprocess_conc('/gpfs/gibbs/pi/n3/Studies/Anticevic.DP5/GLM_EM/sessions/ta6698', [2 3 4 5 6 7 8], 'mshr', 2.500,  0, 'm,m1d,mSq,m1dSq,e', [], 'AllExpsTasks_noL1RO_evRegNum35_PL_ring7_sz20_C.fidl', 'cue:boynton|delay1:boynton|distractor:boynton|delay2:boynton|probe:boynton|cue:boynton>cue_rbf1:1:w:z|cue:boynton>cue_rbf2:2:w:z|cue:boynton>cue_rbf3:3:w:z|cue:boynton>cue_rbf4:4:w:z|cue:boynton>cue_rbf5:5:w:z|cue:boynton>cue_rbf6:6:w:z|cue:boynton>cue_rbf7:7:w:z', '', true, '.dtseries.nii', 'radius:50|fdt:0.50|dvarsmt:3.00|dvarsmet:1.60|after:0|before:0|reject:udvarsme', 'splin', 'boldname=bold|fidlname=AllExpsTasks_noL1RO_evRegNum35_PL_ring7_sz20_C|concname=Atlas_AllExps_noL1RO_pl|surface_smooth=2.000000|volume_smooth=2.000000|voxel_smooth=1.000000|hipass_filter=0.008000|lopass_filter=0.090000|omp_threads=0|framework_path=|wb_command_path=|smooth_mask=nonzero|dilate_mask=/gpfs/gibbs/pi/n3/software/MNAP/library/data/atlases/MNITemplates/MNI152_T1_2mm_brain_mask.nii.gz|glm_matrix=both|glm_residuals=save|glm_name=|bold_tail=_Atlas|ref_bold_tail=|bold_variant=|img_suffix=', '/gpfs/gibbs/pi/n3/Studies/Anticevic.DP5/GLM_EM/sessions/ta6698/images/functional/concs/bold_Atlas_dtseries_Atlas_AllExps_noL1RO_pl_AllExpsTasks_noL1RO_evRegNum35_PL_ring7_sz20_C_s_hpss_res-mm1dmSqm1dSqe.conc.ok'); catch ME, general_report_crash(ME); exit(1), end; exit;"

Test file: 
/gpfs/gibbs/pi/n3/Studies/Anticevic.DP5/GLM_EM/sessions/ta6698/images/functional/concs/bold_Atlas_dtseries_Atlas_AllExps_noL1RO_pl_AllExpsTasks_noL1RO_evRegNum35_PL_ring7_sz20_C_s_hpss_res-mm1dmSqm1dSqe.conc.ok
------------------------------------------------------------


Running preproces conc script v0.9.16 [.dtseries.nii]
-------------------------------------

Parameters:
---------------
       sessionf: /gpfs/gibbs/pi/n3/Studies/Anticevic.DP5/GLM_EM/sessions/ta6698
          bolds: [2  3  4  5  6  7  8]
           doIt: mshr
             TR: 2.50
           omit: 0
           rgss: m,m1d,mSq,m1dSq,e
           task: [0  0]
          efile: AllExpsTasks_noL1RO_evRegNum35_PL_ring7_sz20_C.fidl
   eventrstring: cue:boynton|delay1:boynton|distractor:boynton|delay2:boynton|probe:boynton|cue:boynton>cue_rbf1:1:w:z|cue:boynton>cue_rbf2:2:w:z|cue:boynton>cue_rbf3:3:w:z|cue:boynton>cue_rbf4:4:w:z|cue:boynton>cue_rbf5:5:w:z|cue:boynton>cue_rbf6:6:w:z|cue:boynton>cue_rbf7:7:w:z
        variant: 
      overwrite: 1
           tail: .dtseries.nii
          scrub: radius:50|fdt:0.50|dvarsmt:3.00|dvarsmet:1.60|after:0|before:0|reject:udvarsme
        ignores: splin
           done: /gpfs/gibbs/pi/n3/Studies/Anticevic.DP5/GLM_EM/sessions/ta6698/images/functional/concs/bold_Atlas_dtseries_Atlas_AllExps_noL1RO_pl_AllExpsTasks_noL1RO_evRegNum35_PL_ring7_sz20_C_s_hpss_res-mm1dmSqm1dSqe.conc.ok
        options: boldname=bold|fidlname=AllExpsTasks_noL1RO_evRegNum35_PL_ring7_sz20_C|concname=Atlas_AllExps_noL1RO_pl|surface_smooth=2.000000|volume_smooth=2.000000|voxel_smooth=1.000000|hipass_filter=0.008000|lopass_filter=0.090000|omp_threads=0|framework_path=|wb_command_path=|smooth_mask=nonzero|dilate_mask=/gpfs/gibbs/pi/n3/software/MNAP/library/data/atlases/MNITemplates/MNI152_T1_2mm_brain_mask.nii.gz|glm_matrix=both|glm_residuals=save|glm_name=|bold_tail=_Atlas|ref_bold_tail=|bold_variant=|img_suffix=

Options used:
----------------
        boldname: bold
        concname: Atlas_AllExps_noL1RO_pl
        fidlname: AllExpsTasks_noL1RO_evRegNum35_PL_ring7_sz20_C
  surface_smooth: 2
   volume_smooth: 2
    voxel_smooth: 1
   lopass_filter: 0.09
   hipass_filter: 0.008
  framework_path: 
 wb_command_path: 
     omp_threads: 0
     smooth_mask: nonzero
     dilate_mask: /gpfs/gibbs/pi/n3/software/MNAP/library/data/atlases/MNITemplates/MNI152_T1_2mm_brain_mask.nii.gz
      glm_matrix: both
   glm_residuals: save
        glm_name: 
       bold_tail: _Atlas
   ref_bold_tail: 
    bold_variant: 
      img_suffix: 

---> removing old files:
     ... /gpfs/gibbs/pi/n3/Studies/Anticevic.DP5/GLM_EM/sessions/ta6698/images/functional/bold8_Atlas_s.dtseries.nii
     ... /gpfs/gibbs/pi/n3/Studies/Anticevic.DP5/GLM_EM/sessions/ta6698/images/functional/concs/bold_Atlas_dtseries_AllExpsTasks_noL1RO_evRegNum35_PL_ring7_sz20_C_s.conc--> starting the loop



---> saving conc file ... done!

Smoothing

---> /gpfs/gibbs/pi/n3/Studies/Anticevic.DP5/GLM_EM/sessions/ta6698/images/functional/bold2_Atlas.dtseries.nii 
---> running wb_command -cifti-smoothing
     ... smoothing ... done!

** For an example of how to report an issue, please refer to this post.

Masih, hi!

I just realized that my initial response was not published. We’ve now identified the issue. When the parameter names were harmonized to lowercase, a couple of instances of ‘TR’ parameter were not adjusted. The issue has now been resolved and the fix will be in the next release. A possible workaround before the new release (though not tested) might be to specify TR twice, using lowercase tr and uppercase TR name for the parameter.

All the best,

Grega

1 Like

Thanks Grega. I’ll wait for the next release.