[RESOLVED] Qunex schedule replaces spaces with commas

Description:

When I run the following command

qunex schedule \                                                              
           --command='matlab -nodisplay -nosplash -r "try HCP(true); catch ME; end; quit;"' \
           --settings="SLURM,jobname=HCP_FC,time=00-3:00:00,ntasks=1,cpus-per-task=1,mem-per-cpu=50G,partition=pi_anticevic" 

spaces in the command are replaced with commas as can be seen from the qunex output:

........................ Running Qu|Nex v0.62.5 ........................ 


    ---> Resetting to defaults: 


--- Full Qu|Nex call for command: schedule 

gmri  schedule --command=matlab,-nodisplay,-nosplash,-r,"try,HCP(true);,catch,ME;,end;,quit;" --settings=SLURM,jobname=HCP_FC,time=00-3:00:00,ntasks=1,cpus-per-task=1,mem-per-cpu=50G,partition=pi_anticevic 

--------------------------------------------------------- 



Quantitative Neuroimaging Environment & Toolbox (Qu|Nex) Suite Version 0.62.5

Submitting:
------------------------------
#!/bin/sh
#SBATCH --partition=pi_anticevic
#SBATCH --cpus-per-task=1
#SBATCH --time=00-3:00:00
#SBATCH --ntasks=1
#SBATCH --mem-per-cpu=50G
#SBATCH --job-name=HCP_FC
matlab,-nodisplay,-nosplash,-r,"try,HCP(true);,catch,ME;,end;,quit;"

When I use gmri schedule it works as expected.

Hi Andra┼ż, we will look into this issue and let you know once it is resolved.

This issue is already resolved in the latest released version.