[RESOLVED] Issues when I am downloading container

Description:

HI. I’m trying to download docker container image from qunex gitlab but every time after succeding login I get the error below. I’ve already registered to qunex container registry and I have all of the other requirements. I’ve also tried to install the container tag in example (0.90.1) without success and I can’t find the QuNex README file to see the latest stable container tag.

Call:

sudo docker pull gitlab.qunex.yale.edu:5002/qunex/qunexcontainer/qunex_suite:latest

Logs:

Error response from daemon: pull access denied for gitlab.qunex.yale.edu:5002/qunex/qunexcontainer/qunex_suite, repository does not exist or may require 'docker login': denied: requested access to the resource is denied

Hi Chiara, you are unable to download the container because QuNex is not yet publicly available. It should be available soon, we will let you know once it is.

Thank you, didn’t know it. Do you know when will it be available (just approximately)?

The official release date is spring 2021.

ok, thanks!
is there any possible way that it will be released within the next week?
I’m asking because I’d like to use it for a project I’m working on and this docker seems the most complete for the hcp pipelines

Sorry, but we most likely won’t be able to sort everything out within a week.

Hi again!
Any news about the release?

We are nearly there. Because it is not all in our hands I cannot give an exact date yet though.

1 Like

Hi Chiara, we just released QuNex. If you have any issues with getting access to the container please let us know!

1 Like

Hi there, I got an email that the qunex is now publicly available but I am having the same issue that Chiara reported (denied: access forbidden):

Error response from daemon: Head https://gitlab.qunex.yale.edu:5002/v2/qunex/qunexcontainer/manifests/0.90.6: denied: access forbidden

Error response from daemon: Head https://gitlab.qunex.yale.edu:5002/v2/qunex/qunexcontainer/qunex_suite/manifests/latest: denied: access forbidden

Hi Hadi,

To download the container you need to have Docker (https://www.docker.com/) up and running on the system you are downloading to. Once that is in order, you just execute

docker pull gitlab.qunex.yale.edu:5002/qunex/qunexcontainer:0.90.6

and the container will be pulled to your system.

Cheers, Jure

Thanks, Jure. I can confirm that I have Docker installed already and it is running fine. I still get the same error:

Error response from daemon: Head https://gitlab.qunex.yale.edu:5002/v2/qunex/qunexcontainer/manifests/0.90.6: denied: access forbidden

Ah, you have to login into our Docker repository first. Try

# login
docker login gitlab.qunex.yale.edu:5002 -u <USERNAME>

# pull
docker pull gitlab.qunex.yale.edu:5002/qunex/qunexcontainer:0.90.6

Where you replace <USERNAME> with your username. You can get it, or change it at https://gitlab.qunex.yale.edu/-/profile/account. For example, my username is jdemsar so I would run

docker login gitlab.qunex.yale.edu:5002 -u jdemsar
docker pull gitlab.qunex.yale.edu:5002/qunex/qunexcontainer:0.90.6

That was it. The access denial issue is now fixed. Thanks.