[RESOLVED] Import_bids links hidden files

I’m attempting to onboard bids data into QuNex. The bids are stored in sessions/inbox/BIDS. I have tried this command:

qunex_container import_bids \
    --sessionsfolder="$my_study_folder/sessions" \
    --container="$qunex_container" \
    --overwrite=yes \
  • When I do fslhd 01.nii.gz it gives short read, file may be truncated.
  • When I look at /gpfs/project/fas/n3/Studies/STIMZO/sessions/03052LC_J00/bids/bids2nii.log, some of the source filenames have a ._ in them, e.g.:
  • When I look at the original bids folders, there are some hidden files (I tried to run erase the folder and run again import_bids but I still have the same hidden files):
ls /gpfs/project/fas/n3/Studies/STIMZO/sessions/03052LC_J00/bids/anat/.* -ltr
-rw-rw----+ 1 ll933 anticevic  213  8 avril 09:57 /gpfs/project/fas/n3/Studies/STIMZO/sessions/03052LC_J00/bids/anat/._sub-03052LC_ses-J00_acq-3DT1_rec-nBCyGC_run-1_T1w.json
-rw-rw----+ 2 ll933 anticevic  213  8 avril 09:57 /gpfs/project/fas/n3/Studies/STIMZO/sessions/03052LC_J00/bids/anat/._sub-03052LC_ses-J00_acq-3DT1_rec-nBCyGC_run-1_T1w.nii.gz
-rw-rw----+ 1 ll933 anticevic  213  8 avril 09:57 /gpfs/project/fas/n3/Studies/STIMZO/sessions/03052LC_J00/bids/anat/._anat

I’m uploading the log.
error_import_bids_2022-04-08_10.25.1649427927.308835.log (5.6 KB)


Hi Layla,

It seems like hidden files are messing up the QuNex import logic. Maybe the cleanest course of action would be to:

  1. Create a new QuNex study.
  2. Copy the BIDS data into study’s inbox folder.
  3. Go into the inbox folder and remove all hidden files (e.g. find -type f -name ".*" -delete; rm *~).
  4. Import the data.

If this does not work, I would ask you to provide the location of a couple BIDS sessions that fail, so I can use to debug everything on my end. Thanks!


I created a new QuNex study and imported again the BIDS data into the inbox folder. I do not have any hidden files in the inbox folder, I do have hidden files after importing the data, e.g. in /gpfs/project/fas/n3/Studies/STIMZO.NEW.CENTERS/sessions/03052LC_J00/bids/anat
So I still have the same issue with error_import_bids.

I tried with 2 BIDS sessions:
/gpfs/project/fas/n3/Studies/STIMZO.NEW.CENTERS/sessions/03052LC_J00 and /gpfs/project/fas/n3/Studies/STIMZO.NEW.CENTERS/sessions/07010KB_J00


Layla, just a follow up questions. It seems like the BIDS zip archives contain some files that they should not (e.g., __MACOS folder, etc.), where did you get the archive? These files are making problems for QuNex, a proper fix might take some time. Right now, we are trying to find a quick fix for your issue.