[RESOLVED] Hcp_pre_freesurfer fails for my Siemens Verio sessions

I have troubles to run hcp_pre_freesurfer for my SIEMENS VERIO sessions. It works perfectly with SIEMENS PRISMA acquisitions.

Path to 1 of these sessions:


qunex_container hcp_pre_freesurfer \
 --sessionids="05015PB_J00,05018GA_J00,05025GA_J00,05049LA_J00" \
 --sessionsfolder="/gpfs/project/fas/n3/Studies/STIMZO/sessions" \
 --sessions="/gpfs/project/fas/n3/Studies/STIMZO/processing/batch_tours.txt" \
 --overwrite="yes" \
 --container="$qunex_container" \

container = qunex_suite-0.93.6.sif
I also tried the command with qunexdev —> same result

Path to comlogs: /gpfs/project/fas/n3/Studies/STIMZO/processing/logs/comlogs

The comlog indicates an error in T2wToT1wDistortionCorrectAndReg.sh—> I checked the outputs of T2wToT1wDistortionCorrectAndReg.sh: T1w_acpc_dc_brain and T1w_acpc_dc_brain (these sessions don’t have any T2). They both seem fine.

error_hcp_pre_freesurfer_05025GA_J00.log (18.3 KB)


Hi Layla!

This seems like an issue with FSL imcp command again. We’ve run in to a similar issue before [RESOLVED] Potential bug in overwrite function. The HCP pipeline uses imcp internally, but imcp does not overwrite existing files by default. We might need to manually remove more files in qunex when the overwrite is set to yes.

For now, can you try removing the MNINonLinear, T1w, and T2w folder in sessions/<session id>/hcp/<session id> for problematic sessions.

Btw, I saw you were able to run this session successfully in May done_hcp_pre_freesurfer_05025GA_J00_2022-05-17_21.29.38.432933.log


I removed manually the files and ran again the command and it worked, thanks!