[RESOLVED] Get_dicom_fields skips all dicoms

get_dicom_fields command seems to skip valid dicoms (qunex_suite-0.93.6.sif version). I tried the command with own data as well as with HCPA001.zip dicoms and it skipped all dicom files in both datasets resulting in empty dicomFields.csv.

—> Inspecting /tmp/tmpnk9v9mwu/340/340-
… not a dicom file … skipping


Hi Petr,

There are several bugs in the get_dicom_fields function. This feature is considered deprecated and not listed in the list of supported commands qunex -a . It hasn’t been tested since it was migrated from Python 2.

Currently, we managed to get the get_dicom_fields function working again, which will be included in the next release, hopefully this week. However, if you are following the wiki page on de-identification, the next step still doesn’t work. May I ask what you are trying to achieve with this command?


Hi Lining,
thank you for your reply - I’d like to de-identify dicoms so I intended to use the change_dicom_files command as well and would be grateful if updated version was included in the next release.
Many thanks,

Hi, the issue has now been resolved and the deidentification will be operational again in the next release (hopefully by the end of this week). We had to remove the hash operation from the command as it has several security and design flaws.