[RESOLVED] createStatsReport doesn't work well when using parsessions

When I use createStatsReport in parallel manner, session data in bold_movement_report.txt is written in “random” order, e.g. it looks like this

117021	boldfixica 3	frame_dspl	0.1222225	0.1103279	0.4079639	0.06054124	
117021	boldfixica 4	mean	-0.04203504	0.05284625	0.04306959	0.1808803	-0.0599862	0.04993382	
117021	boldfixica 4	sd	0.04441326	0.03541267	0.09113935	0.1500692	0.06496679	0.05766745	
117021	boldfixica 4	span	0.290598	0.164921	0.428368	0.61381	0.292953	0.331914	
117021	boldfixica 4	max	0.155582	0.070873	0.197269	0.236632	0.103648	0.242361	
117021	boldfixica 4	md	0.03558767	0.01380091	0.02742078	0.03200083	0.01701846	0.03166174	
117021	boldfixica 4	med	0.029973	0.009706	0.020518	0.019767	0.011803	0.023577	
117021	boldfixica 4	md2_max	0.008140287	0.003047101	0.004880784	0.005060327	0.002794344	0.00413625	
117021	boldfixica 4	frame_dspl	0.1472169	0.1281574	0.6053442	0.08784174	
session	run	stat	dx	dy	dz	X	Y	Z	
178748	boldfixica 1	mean	-0.003588607	0.0588877	0.1037723	-0.1306637	-0.2889648	0.1372117	
178748	boldfixica 1	sd	0.08173968	0.2554376	0.911654	0.3750798	0.1292983	0.08274297	
178748	boldfixica 1	span	1.129249	1.506431	5.524918	3.222257	0.881496	0.742553	
178748	boldfixica 1	max	0.726949	0.426914	1.646496	1.718816	0.751835	0.449256	
178748	boldfixica 1	md	0.03

Mostly this is not really an issue, except for the header line which should always be at the top line.

Call:

gmri createStatsReport \
    --sessions="/gpfs/project/fas/n3/Studies/Connectome/processing/subjectsn1096-allRS-MSMall-FIXICA_am.txt" \
    --sessionsfolder="/gpfs/project/fas/n3/Studies/Connectome/subjects" \
    --logfolder="/gpfs/project/fas/n3/Studies/Connectome/processing/logs/createStatsReport2" \
    --overwrite="no" \
    --bolds="rest" \
    --boldname='bold' \
    --hcp_cifti_tail='' \
    --bold_tail='' \
    --overwrite="yes" \
    --img_suffix='.am' \
    --parsessions=20 \
    --scheduler="SLURM,jobname=goodjob,time=0-02:00:00,ntasks=20,cpus-per-task=1,mem-per-cpu=10000,partition=pi_anticevic"

Hi Andraz, we will assign a developer to this issue and will let you know once it has been resolved.

We fixed this issue, an updated version of QuNex will be available shortly.