General_plot_bold_timeseries error

Hello, I used an example from QuNex documentation to test run general_plot_bold_timeseries, but received an error.

qunex general_plot_bold_timeseries \
    --images="/gpfs/gibbs/pi/n3/Studies/Pushkarskaya.PVDM/sessions/pb7906/images/functional/bold1.nii.gz" \
    --elements="type=stats|stats>plotdata=fd,imageindex=1>plotdata=dvarsme,imageindex=1;type=signal|name=V|imageindex=1|maskindex=1;type=signal|name=WM|imageindex=1|maskindex=1;type=signal|name=GM|imageindex=1|maskindex=1" \
    --masks="/gpfs/gibbs/pi/n3/Studies/Pushkarskaya.PVDM/sessions/pb7906/images/segmentation/freesurfer/mri/aparc+aseg_bold.nii.gz" \
    --filename='pb7906-BoldTSPlot.pdf' \
    --skip="0" \
    --sessionid="pb7906" \
    --verbose="true"

The error:

Running general_plot_bold_timeseries
====================
 ---> reading images and maps
datatype =
    'int32'
 ---> parsing elements
 ---> added ROI codes for V.
 ---> masking with ROI!
 ---> added V of size 7
 ---> added ROI codes for WM.
 ---> masking with ROI!
 ---> added WM of size 30
 ---> added ROI codes for GM.
 ---> masking with ROI!
 ---> added GM of size 60
Matlab Error! Processing Failed!
Dimensions of arrays being concatenated are not consistent.

ERROR: general_plot_bold_timeseries failed! Please check output / log!

No logs were created

Hi, there is a bug in general_plot_bold_timeseries. We have assigned a developer to work on it.

1 Like

@helen.pushkarskaya We have fixed the bug, the updated function will be available in the next QuNex release (0.100).

1 Like